summaryrefslogtreecommitdiff
path: root/target/u-boot/Config.in
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-03 15:50:38 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-03 15:50:38 +0000
commitc7066b18079daef160592168e51479e82ae4f586 (patch)
tree132fbd0483eaa5c11c438cb6ff28b2b6ddc575a1 /target/u-boot/Config.in
parent98eefe7074bd385eb5b9f41de97e97587bf15d9d (diff)
Generate an autoscript for configuring u-boot in $(BINARIES_DIR)
mkimage the autoscript to autoscript.$(PROJECT)- Move build of u-boot-1.2.0-atmel to target/u-boot Only visible for AT91 targets. Fetch prepatched 1.2.0-atmel tarball from $(BR2_ATMEL_MIRROR) Rest from normal location. Introduce U_BOOT_CONFIGURE_OPTS Set to NOSOFT_FLOAT for u-boot-1.2.0-atmel Disable target/device/Atmel/u-boot Keep files in target/device/Atmel/u-boot during a test period. Files: M target/device/Atmel/Makefile.in M target/device/Atmel/Config.in M target/u-boot/Makefile.in M target/u-boot/Config.in A target/u-boot/1.2.0-atmel
Diffstat (limited to 'target/u-boot/Config.in')
-rw-r--r--target/u-boot/Config.in18
1 files changed, 11 insertions, 7 deletions
diff --git a/target/u-boot/Config.in b/target/u-boot/Config.in
index a58542ba4..2f3963b15 100644
--- a/target/u-boot/Config.in
+++ b/target/u-boot/Config.in
@@ -1,12 +1,5 @@
-config BR2_TARGET_CUSTOM_UBOOT
- bool
- help
- A target can "select" this to disable
- the build of vanilla u-boot.
-
menuconfig BR2_TARGET_UBOOT
bool "Das U-Boot Boot Monitor"
- depends on !BR2_TARGET_CUSTOM_UBOOT
help
Build "Das U-Boot" Boot Monitor
@@ -37,6 +30,11 @@ config BR2_TARGET_UBOOT_1_3_4
bool "u-boot-1.3.4"
depends on BR2_TARGET_UBOOT
+config BR2_TARGET_UBOOT_1_2_0_ATMEL
+ bool "u-boot-1.2.0-atmel"
+ depends on BR2_TARGET_AT91
+ depends on BR2_TARGET_UBOOT
+
config BR2_TARGET_UBOOT_2009_01
bool "u-boot-2009.01"
depends on BR2_TARGET_UBOOT
@@ -48,8 +46,14 @@ config BR2_UBOOT_VERSION
default "2009.01-rc1" if BR2_TARGET_UBOOT_2009_01_RC1
default "2008.10" if BR2_TARGET_UBOOT_2008_10
default "1.3.4" if BR2_TARGET_UBOOT_1_3_4
+ default "1.2.0-atmel" if BR2_TARGET_UBOOT_1_2_0_ATMEL
default "2009.01" if BR2_TARGET_UBOOT_2009_01
+config BR2_U_BOOT_SITE
+ string
+ default "$(BR2_ATMEL_MIRROR)" if BR2_TARGET_UBOOT_1_2_0_ATMEL
+ default "ftp://ftp.denx.de/pub/u-boot"
+
config BR2_TARGET_UBOOT_CUSTOM_PATCH
string "custom patch"
depends on BR2_TARGET_UBOOT