summaryrefslogtreecommitdiff
path: root/target/u-boot/Makefile.in
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-19 22:42:03 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-19 22:42:03 +0000
commit5a4676144660f6e92bbe5e0de6b38094df155021 (patch)
tree064a71e50fa34e6a26c44b5597b3c4e1fc45556a /target/u-boot/Makefile.in
parentb71c76a10a21320a9401cc4246079e9f4f47fae1 (diff)
Bump u-boot to -2009.01-rc3, and add possibility to apply the arch-at91 patches if using an at91
Diffstat (limited to 'target/u-boot/Makefile.in')
-rw-r--r--target/u-boot/Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index baf331da7..1386e03a7 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -88,6 +88,9 @@ $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
toolchain/patch-kernel.sh $(U_BOOT_DIR) target/u-boot/$(U_BOOT_VERSION) \
u-boot-$(U_BOOT_VERSION)-\*.patch \
u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
+ifneq ($(strip $(U_BOOT_ARCH_PATCH_DIR)),"")
+ toolchain/patch-kernel.sh $(U_BOOT_DIR) $(U_BOOT_ARCH_PATCH_DIR) \*.patch
+endif
ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH)),"")
@mkdir -p $(U_BOOT_PATCH_DIR)
cp -dpr $(BR2_TARGET_UBOOT_CUSTOM_PATCH) $(U_BOOT_PATCH_DIR)