summaryrefslogtreecommitdiff
path: root/target/u-boot/Makefile.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-12-18 09:33:45 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-18 09:33:45 +0100
commitcc9fb53408964b278d01ec9678f239c9ae28970d (patch)
treed1ee6a4c5441abc1fbf0be3515bc9ea76809b851 /target/u-boot/Makefile.in
parentd77594ccd7f81ac99af68e00bae1eb6b816fc022 (diff)
target/u-boot: add 2009.11 and update target mkimage so it builds with 2009.11
In 2009.11, a number of extra files are needed to build mkimage. Adjust the makefile to add those if available, so it builds with both 2009.11 and older releases. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target/u-boot/Makefile.in')
-rw-r--r--target/u-boot/Makefile.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index dd45b42ac..5efbd54d2 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -175,8 +175,11 @@ $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/$(U_BOOT_BIN)
mkdir -p $(@D)
$(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(U_BOOT_DIR)/tools \
-DUSE_HOSTCC -o $@ \
- $(U_BOOT_DIR)/tools/mkimage.c $(U_BOOT_DIR)/common/image.c \
+ $(U_BOOT_DIR)/common/image.c \
+ $(wildcard $(addprefix $(U_BOOT_DIR)/tools/,default_image.c \
+ fit_image.c kwbimage.c mkimage.c)) \
$(addprefix $(U_BOOT_DIR)/lib_generic/,crc32.c md5.c sha1.c) \
+ $(U_BOOT_DIR)/tools/os_support.c \
$(U_BOOT_DIR)/libfdt/fdt*.c
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@