summaryrefslogtreecommitdiff
path: root/target/ubifs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec /target/ubifs
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target/ubifs')
-rw-r--r--target/ubifs/Config.in88
-rw-r--r--target/ubifs/ubifsroot.mk25
2 files changed, 0 insertions, 113 deletions
diff --git a/target/ubifs/Config.in b/target/ubifs/Config.in
deleted file mode 100644
index 9fa510e75..000000000
--- a/target/ubifs/Config.in
+++ /dev/null
@@ -1,88 +0,0 @@
-config BR2_TARGET_ROOTFS_UBIFS
- bool "ubifs root filesystem"
- help
- Build a ubifs root filesystem
-
-config BR2_TARGET_ROOTFS_UBIFS_LEBSIZE
- hex "UBI logical erase block size"
- depends on BR2_TARGET_ROOTFS_UBIFS
- default 0x1f800
-
-config BR2_TARGET_ROOTFS_UBIFS_MINIOSIZE
- hex "UBI minimum I/O size"
- depends on BR2_TARGET_ROOTFS_UBIFS
- default 0x800
- help
- Some comment required here
-
-config BR2_TARGET_ROOTFS_UBIFS_MAXLEBCNT
- int "Maximum LEB count"
- depends on BR2_TARGET_ROOTFS_UBIFS
- default 2048
- help
- Some comment required here
-
-choice
- prompt "ubifs runtime compression"
- default BR2_TARGET_ROOTFS_UBIFS_RT_LZO
- depends on BR2_TARGET_ROOTFS_UBIFS
- help
- Select which compression format to use at run-time within
- the ubifs file system.
-
-config BR2_TARGET_ROOTFS_UBIFS_RT_NONE
- bool "no compression"
- help
- Don't use run-time compression.
-
-config BR2_TARGET_ROOTFS_UBIFS_RT_ZLIB
- bool "gzip"
- help
- Use zlib compression at run-time.
-
-config BR2_TARGET_ROOTFS_UBIFS_RT_LZO
- bool "lzo"
- help
- Use lzo compression at run-time.
-
-endchoice
-
-choice
- prompt "Compression method"
- default BR2_TARGET_ROOTFS_UBIFS_NONE
- depends on BR2_TARGET_ROOTFS_UBIFS
- help
- Select which compression format to compress the final image
- into.
-
-config BR2_TARGET_ROOTFS_UBIFS_NONE
- bool "no compression"
- help
- Do not compress the ubifs filesystem.
-
-config BR2_TARGET_ROOTFS_UBIFS_GZIP
- bool "gzip"
- help
- Do compress the ubifs filesystem with gzip.
- Note that you either have to have gzip installed on your
- host or select to build a gzip for your host. See the
- packages submenu.
-
-config BR2_TARGET_ROOTFS_UBIFS_BZIP2
- bool "bzip2"
- help
- Do compress the ubifs filesystem with bzip2.
- Note that you either have to have bzip2 installed on your
- host or select to build a bzip2 for your host. See the
- packages submenu.
-
-config BR2_TARGET_ROOTFS_UBIFS_LZMA
- bool "lzma"
- help
- Do compress the ubifs filesystem with lzma.
- Note that you either have to have lzma installed on your
- host or select to build a lzma for your host. See the
- packages submenu.
-
-endchoice
-
diff --git a/target/ubifs/ubifsroot.mk b/target/ubifs/ubifsroot.mk
deleted file mode 100644
index 0fad23421..000000000
--- a/target/ubifs/ubifsroot.mk
+++ /dev/null
@@ -1,25 +0,0 @@
-#############################################################
-#
-# Build the ubifs root filesystem image
-#
-#############################################################
-
-UBIFS_OPTS := -e $(BR2_TARGET_ROOTFS_UBIFS_LEBSIZE) -c $(BR2_TARGET_ROOTFS_UBIFS_MAXLEBCNT) -m $(BR2_TARGET_ROOTFS_UBIFS_MINIOSIZE)
-
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_ZLIB),y)
-UBIFS_OPTS += -x zlib
-endif
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_LZI),y)
-UBIFS_OPTS += -x lzo
-endif
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_NONE),y)
-UBIFS_OPTS += -x none
-endif
-
-ROOTFS_UBIFS_DEPENDENCIES = host-mtd
-
-define ROOTFS_UBIFS_CMD
- $(HOST_DIR)/usr/sbin/mkfs.ubifs -d $(TARGET_DIR) $(UBIFS_OPTS) -o $$@
-endef
-
-$(eval $(call ROOTFS_TARGET,ubifs)) \ No newline at end of file