summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-06-29 20:56:49 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-06-29 20:56:49 +0200
commit99da30bf5d14f465ad18bbf204d09f84b427d52d (patch)
tree2395cc4259c699e2cd24232a10109921d47557ba /target
parent2945b06610197422b17dd271e695164088f06f90 (diff)
u-boot: target tools: use library files from their original location
u-boot 2009.06 changed the tools/ logic, and no longer adds symbolic links to the needed library files in the tools directory. Fix build by referencing the library files in their original location. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target')
-rw-r--r--target/u-boot/Makefile.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index cd184045d..b74e43aab 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -186,16 +186,19 @@ $(U_BOOT_TOOLS): $(U_BOOT_DIR)/$(U_BOOT_BIN)
$(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/$(U_BOOT_BIN)
mkdir -p $(@D)
- $(TARGET_CC) -I$(U_BOOT_DIR)/include -DUSE_HOSTCC -o $@ \
- $(U_BOOT_DIR)/tools/mkimage.c \
- $(addprefix $(U_BOOT_DIR)/tools/,crc32.c image.c md5.c sha1.c fdt*.c)
+ $(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(U_BOOT_DIR)/tools \
+ -DUSE_HOSTCC -o $@ \
+ $(U_BOOT_DIR)/tools/mkimage.c $(U_BOOT_DIR)/common/image.c \
+ $(addprefix $(U_BOOT_DIR)/lib_generic/,crc32.c md5.c sha1.c) \
+ $(U_BOOT_DIR)/libfdt/fdt*.c
+
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
$(TARGET_DIR)/usr/sbin/fw_printenv: $(U_BOOT_DIR)/$(U_BOOT_BIN)
mkdir -p $(@D)
$(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(LINUX_HEADERS_DIR)/include \
-DUSE_HOSTCC -o $@ \
- $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/tools/crc32.c
+ $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/lib_generic/crc32.c
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv