summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-02-06 18:19:38 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-02-06 18:19:38 +0000
commit02f71aab47835e7220e2b1039bcda4d0c5657db0 (patch)
treec4a14c8fb83fdec69a34065d93777e9960ea0831 /target
parent4cdc4206218e8e2ed3bc5a31e2b5e157ec43f67c (diff)
Support building using an external toolchain. Questions to the mailing list and all other comments to <biteme@devnull.com>.
Diffstat (limited to 'target')
-rw-r--r--target/Makefile.in3
-rw-r--r--target/device/Makefile.in3
2 files changed, 3 insertions, 3 deletions
diff --git a/target/Makefile.in b/target/Makefile.in
index a65b74019..7ec139db9 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -7,4 +7,7 @@ include target/powerpc/Makefile.in
# and finally build the filesystems/tarballs
include target/*/*.mk
# kernel rules
+ifeq ($(BR2_PACKAGE_LINUX),y)
+TARGETS+=linux26
+endif
include target/linux*.mk
diff --git a/target/device/Makefile.in b/target/device/Makefile.in
index fd9f03f11..c2d04a97a 100644
--- a/target/device/Makefile.in
+++ b/target/device/Makefile.in
@@ -1,6 +1,3 @@
TARGET_DEVICE_DEPMOD:=target/device/x86/depmod.pl
-include target/device/*/Makefile.in
-ifeq ($(BR2_PACKAGE_LINUX),y)
-TARGETS+=linux26
-endif