summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-02 22:39:25 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:32 +0200
commit4bcefe826bbc1bf550a091e7ae86ad5ee7946909 (patch)
treebf5801fa833d8e5fcd80bb13a72eb1022df2074f /target
parent57579378e1812123c4c120526c05b84e8a79944d (diff)
target/cpio: cleanup
* Remove the dependency on BR2_HOST_FAKEROOT, since we don't have config option for host tools. * Remove a few useless things. * Check that cpio is available on the host in toolchain/dependencies/dependencies.sh. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target')
-rw-r--r--target/cpio/Config.in1
-rw-r--r--target/cpio/cpioroot.mk17
2 files changed, 3 insertions, 15 deletions
diff --git a/target/cpio/Config.in b/target/cpio/Config.in
index 83bdd21e0..4ee1037d4 100644
--- a/target/cpio/Config.in
+++ b/target/cpio/Config.in
@@ -1,6 +1,5 @@
config BR2_TARGET_ROOTFS_CPIO
bool "cpio the root filesystem"
- select BR2_HOST_FAKEROOT
help
Build a cpio archive of the root filesystem
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
index 2197d1050..021847ffd 100644
--- a/target/cpio/cpioroot.mk
+++ b/target/cpio/cpioroot.mk
@@ -12,17 +12,15 @@ CPIO_ROOTFS_COMPRESSOR_PREREQ:=
ifeq ($(BR2_TARGET_ROOTFS_CPIO_GZIP),y)
CPIO_ROOTFS_COMPRESSOR:=gzip -9 -c
CPIO_ROOTFS_COMPRESSOR_EXT:=gz
-#CPIO_ROOTFS_COMPRESSOR_PREREQ:= gzip-host
endif
ifeq ($(BR2_TARGET_ROOTFS_CPIO_BZIP2),y)
CPIO_ROOTFS_COMPRESSOR:=bzip2 -9 -c
CPIO_ROOTFS_COMPRESSOR_EXT:=bz2
-#CPIO_ROOTFS_COMPRESSOR_PREREQ:= bzip2-host
endif
ifeq ($(BR2_TARGET_ROOTFS_CPIO_LZMA),y)
-CPIO_ROOTFS_COMPRESSOR:=lzma -9 -c
+CPIO_ROOTFS_COMPRESSOR:=$(LZMA) -9 -c
CPIO_ROOTFS_COMPRESSOR_EXT:=lzma
-CPIO_ROOTFS_COMPRESSOR_PREREQ:= lzma-host
+CPIO_ROOTFS_COMPRESSOR_PREREQ:= host-lzma
endif
ifneq ($(CPIO_ROOTFS_COMPRESSOR),)
@@ -32,7 +30,6 @@ CPIO_TARGET := $(CPIO_BASE)
endif
ROOTFS_CPIO_COPYTO:=$(call qstrip,$(BR2_TARGET_ROOTFS_CPIO_COPYTO))
-#
cpioroot-init:
rm -f $(TARGET_DIR)/init
@@ -54,7 +51,7 @@ endif
>> $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
$(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
- #-@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
+ -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
ifeq ($(CPIO_ROOTFS_COMPRESSOR),)
ifneq ($(ROOTFS_CPIO_COPYTO),)
$(Q)cp -f $(CPIO_BASE) $(ROOTFS_CPIO_COPYTO)
@@ -69,14 +66,6 @@ ifneq ($(ROOTFS_CPIO_COPYTO),)
endif
endif
-cpioroot: $(CPIO_TARGET)
-
-cpioroot-source:
-
-cpioroot-clean:
-
-cpioroot-dirclean:
-
#############################################################
#
# Toplevel Makefile options