summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-31 17:36:43 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-31 17:36:43 +0000
commitf0be91fd176ab4816eb1219f1f392b3b3edb0665 (patch)
tree9e5b5ac4292e16d5b1ccac1c9d86c24b77098dbc /target
parent67bed999ab1b926f3484eac04d6ca748debadcef (diff)
- reenable linux26
Diffstat (limited to 'target')
-rw-r--r--target/device/Config.in10
-rw-r--r--target/device/Makefile.in3
-rw-r--r--target/device/x86/Makefile.in2
-rw-r--r--target/device/x86/i386/Makefile.in1
4 files changed, 4 insertions, 12 deletions
diff --git a/target/device/Config.in b/target/device/Config.in
index 788822f0c..53ee05569 100644
--- a/target/device/Config.in
+++ b/target/device/Config.in
@@ -1,16 +1,8 @@
menu "Board Support Options"
-config BR2_TARGET_GENERIC
- bool "linux kernel"
- default n
- select BR2_PACKAGE_LINUX
- help
- Architecture or board dependant linux kernel.
-
config BR2_PACKAGE_LINUX
- bool "linux"
+ bool "linux kernel"
default n
- depends BR2_TARGET_GENERIC
help
The Linux kernel.
http://www.kernel.org/
diff --git a/target/device/Makefile.in b/target/device/Makefile.in
index c2d04a97a..fd9f03f11 100644
--- a/target/device/Makefile.in
+++ b/target/device/Makefile.in
@@ -1,3 +1,6 @@
TARGET_DEVICE_DEPMOD:=target/device/x86/depmod.pl
-include target/device/*/Makefile.in
+ifeq ($(BR2_PACKAGE_LINUX),y)
+TARGETS+=linux26
+endif
diff --git a/target/device/x86/Makefile.in b/target/device/x86/Makefile.in
index 93041711b..e3a995a7f 100644
--- a/target/device/x86/Makefile.in
+++ b/target/device/x86/Makefile.in
@@ -1,5 +1,3 @@
-ifeq ($(strip $(BR2_TARGET_GENERIC)),y)
ifeq ($(strip $(BR2_i386)),y)
include target/device/x86/i386/Makefile.in
endif
-endif
diff --git a/target/device/x86/i386/Makefile.in b/target/device/x86/i386/Makefile.in
index 0e6ab6148..876304b7e 100644
--- a/target/device/x86/i386/Makefile.in
+++ b/target/device/x86/i386/Makefile.in
@@ -5,4 +5,3 @@ LINUX26_KCONFIG=$(BR2_BOARD_PATH)/linux26.config
endif
LINUX26_FORMAT=bzImage
-TARGETS+=linux26