summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-12 22:53:52 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-14 00:25:18 +0100
commitfb7226ca2f185577f656b422f9e6a73304de71e9 (patch)
tree574c8a05b6d5d9a4c2541b83fd4319f607708c85 /target
parent7e2bf63080cc0011c84ee46ee2aba161569154c5 (diff)
target: support generic getty with sysvinit inittabs
In sysvinit inittab the "id" field (first field) must be no longer than 4 bytes, and is not used by init to determine the output terminal. Therefore, we adjust the strategy used to modify the inittab file according to the getty configuration. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target')
-rw-r--r--target/generic/Makefile.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/generic/Makefile.in b/target/generic/Makefile.in
index 1ef2a9d82..3a750c3b4 100644
--- a/target/generic/Makefile.in
+++ b/target/generic/Makefile.in
@@ -11,10 +11,16 @@ target-generic-issue:
mkdir -p $(TARGET_DIR)/etc
echo "$(TARGET_GENERIC_ISSUE)" > $(TARGET_DIR)/etc/issue
-target-generic-getty:
+target-generic-getty-busybox:
$(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
$(TARGET_DIR)/etc/inittab
+# In sysvinit inittab, the "id" must not be longer than 4 bytes, so we
+# skip the "tty" part and keep only the remaining.
+target-generic-getty-sysvinit:
+ $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(shell echo $(TARGET_GENERIC_GETTY) | tail -c+4)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
+ $(TARGET_DIR)/etc/inittab
+
ifneq ($(TARGET_GENERIC_HOSTNAME),)
TARGETS += target-generic-hostname
endif
@@ -24,5 +30,9 @@ TARGETS += target-generic-issue
endif
ifeq ($(BR2_TARGET_GENERIC_GETTY),y)
-TARGETS += target-generic-getty
+ifeq ($(BR2_PACKAGE_SYSVINIT),y)
+TARGETS += target-generic-getty-sysvinit
+else
+TARGETS += target-generic-getty-busybox
+endif
endif