summaryrefslogtreecommitdiff
path: root/toolchain/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-01 22:16:28 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-01 22:16:28 +0000
commit3096f34d27f32fc179ca051ad78ac9ee2165c72e (patch)
tree4e8bf2d890181cc77f0fd74e339d6db6721c2331 /toolchain/Makefile.in
parent961229caf56a6a3e3bc9fd58805d8e83dd6a84ae (diff)
- add BR2_PREFER_STATIC_LIB config option to be able to select if we prefer to build static or dynamic libs/bins.
- depending on the BR2_GNU_BUILD_SUFFIX, set the respective EXEEXT, LIBEXT, SHREXT extensions for use on the target. Thanks to Tom for suplying a diff which implements these.
Diffstat (limited to 'toolchain/Makefile.in')
-rw-r--r--toolchain/Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index ca798bf6b..6f7cc013d 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -10,6 +10,12 @@ else
MULTILIB:=--disable-multilib
endif
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+PREFERRED_LIB_FLAGS:=--enable-static --disable-shared
+else
+PREFERRED_LIB_FLAGS:=--disable-static --enable-shared
+endif
+
# FIXME -- this is temporary
OPTIMIZE_FOR_CPU=$(ARCH)