summaryrefslogtreecommitdiff
path: root/toolchain/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-03-21 10:55:02 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-03-21 10:55:02 +0000
commit52742cfc2f0c84640b487396efb3fdea4d3da1b0 (patch)
tree2561b43375edc8b5d1bc9b6b4bb60189b884c597 /toolchain/Makefile.in
parent22c0b6ee5cdfa9574f9a59845b35e9a818f66a80 (diff)
- add CFLAGS_COMBINE check
Diffstat (limited to 'toolchain/Makefile.in')
-rw-r--r--toolchain/Makefile.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 84e2ae42f..ca798bf6b 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -16,6 +16,8 @@ OPTIMIZE_FOR_CPU=$(ARCH)
# late binding check to see if the target cc supports -fwhole-program
CFLAGS_WHOLE_PROGRAM = $(call cc-option,-fwhole-program,)
+# gcc-3.4 would need -combine, I only support 4.2, which correctly uses '--'
+CFLAGS_COMBINE = $(call cc-option,--combine,)
# gcc has a bunch of needed stuff....
include toolchain/gcc/Makefile.in