summaryrefslogtreecommitdiff
path: root/toolchain/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-28 12:07:04 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-28 23:21:45 +0200
commit5575d205c35942d992db636a4f7caa246340bd0c (patch)
tree6ae43969230dafadd05852e85ff55dd4e26f7b3c /toolchain/Makefile.in
parent6d4a992e2b817cc14276c68e0321edaf66450cf3 (diff)
toolchain: remove multilib
Supporting multilib is much more than just passing --enable-multilib to gcc. You have to actually build the C library several times (once for each multilib variant you want to support in your toolchain), and to pass MULTILIB_OPTIONS/MULTILIB_EXCEPTIONS values to gcc to let it know the set of multilib variants you're interested in. Since we'll probably never support multilib toolchains in Buildroot, just get rid of this BR2_ENABLE_MULTILIB option. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/Makefile.in')
-rw-r--r--toolchain/Makefile.in6
1 files changed, 0 insertions, 6 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index d1af87747..371509f4e 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -4,12 +4,6 @@ else
THREADS:=--enable-threads
endif
-ifeq ($(BR2_ENABLE_MULTILIB),y)
-MULTILIB:=--enable-multilib
-else
-MULTILIB:=--disable-multilib
-endif
-
BR2_CONFIGURE_DEVEL_SYSROOT=--with-sysroot=$(TOOLCHAIN_DIR)/uClibc_dev/
BR2_CONFIGURE_STAGING_SYSROOT=--with-sysroot=$(STAGING_DIR)
BR2_CONFIGURE_BUILD_TOOLS=--with-build-time-tools=$(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin