summaryrefslogtreecommitdiff
path: root/toolchain/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-20 11:26:36 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-20 11:26:36 +0000
commit8027784c3589198d3ba4b9a24b26c361462f1946 (patch)
tree2a666abbe874c367997a2b4830a16225086324cc /toolchain/Makefile.in
parent2c649045197156221cc1d3d6328abb1c405db700 (diff)
- add full sysroot support for non-ancient toolchains.
- start to separate usr/lib and lib to match normal system-layout
Diffstat (limited to 'toolchain/Makefile.in')
-rw-r--r--toolchain/Makefile.in21
1 files changed, 17 insertions, 4 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 6f7cc013d..703e8e6db 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -10,13 +10,26 @@ else
MULTILIB:=--disable-multilib
endif
-ifeq ($(BR2_PREFER_STATIC_LIB),y)
-PREFERRED_LIB_FLAGS:=--enable-static --disable-shared
+ifeq ($(BR2_TOOLCHAIN_SYSROOT),y)
+BR2_SYSROOT_PREFIX=# nothing, straight into /usr
+BR2_SYSROOT_STAGING_DESTDIR=DESTDIR=$(STAGING_DIR)/
+BR2_SYSROOT_TARGET_DESTDIR=DESTDIR=$(TARGET_DIR)/
+BR2_CONFIGURE_DEVEL_SYSROOT=--with-sysroot=$(TOOL_BUILD_DIR)/uClibc_dev/
+BR2_CONFIGURE_STAGING_SYSROOT=--with-sysroot=$(STAGING_DIR)
+BR2_CONFIGURE_BUILD_TOOLS=--with-build-time-tools=$(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin
+BR2_SYSROOT=--sysroot=$(STAGING_DIR)/
+BR2_ISYSROOT=-isysroot $(STAGING_DIR)
else
-PREFERRED_LIB_FLAGS:=--disable-static --enable-shared
+BR2_SYSROOT_PREFIX=$(STAGING_DIR)
+BR2_SYSROOT_STAGING_DESTDIR=# nothing
+BR2_SYSROOT_TARGET_DESTDIR=# nothing
+BR2_CONFIGURE_DEVEL_SYSROOT=--with-sysroot=$(TOOL_BUILD_DIR)/uClibc_dev/
+BR2_CONFIGURE_STAGING_SYSROOT=# nothing
+BR2_CONFIGURE_BUILD_TOOLS=# nothing
+BR2_SYSROOT=# nothing
+BR2_ISYSROOT=#nothing
endif
-
# FIXME -- this is temporary
OPTIMIZE_FOR_CPU=$(ARCH)