summaryrefslogtreecommitdiff
path: root/toolchain/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-12 13:38:06 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-12 13:38:06 +0000
commit99cf7293f9eb943e00e2ebca6eee0e36eaa801bd (patch)
tree1ae33b5d2518286eafc5154cdecb2fd9ed0e3f97 /toolchain/Makefile.in
parente5b36a686c563bc667406b9e148e9a72948505be (diff)
- add cc-option and use it to check for stuff that is benefical for PREFER_IMA
- backport the libbackend.o gcov-iov.h dependency fixup from 4.2 to 4.0
Diffstat (limited to 'toolchain/Makefile.in')
-rw-r--r--toolchain/Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 1a2c0f26f..84e2ae42f 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -14,5 +14,8 @@ endif
# FIXME -- this is temporary
OPTIMIZE_FOR_CPU=$(ARCH)
+# late binding check to see if the target cc supports -fwhole-program
+CFLAGS_WHOLE_PROGRAM = $(call cc-option,-fwhole-program,)
+
# gcc has a bunch of needed stuff....
include toolchain/gcc/Makefile.in