summaryrefslogtreecommitdiff
path: root/toolchain/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-25 14:28:47 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-07 08:14:40 +0200
commitdc67c7f4dc3b3dbd0c71c2917373deab70f75b7a (patch)
tree847b99af08d9dab2e97ee32f00285e94bf6abad8 /toolchain/Makefile.in
parentb07030a708293756e25edd6432ed02cc53ff758e (diff)
Rework sysroot option handling
The external toolchain and internal toolchain cases both need to use the --sysroot option, and they have almost identical LDFLAGS/CFLAGS/CXXFLAGS definition, so we can factorize these definitions. Moreover, the --isysroot option is implied by --sysroot so there's no need to specify both. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/Makefile.in')
-rw-r--r--toolchain/Makefile.in2
1 files changed, 0 insertions, 2 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 5d0e5a1c2..e5fae1f56 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -15,8 +15,6 @@ BR2_SYSROOT_TARGET_DESTDIR=DESTDIR=$(TARGET_DIR)/
BR2_CONFIGURE_DEVEL_SYSROOT=--with-sysroot=$(TOOLCHAIN_DIR)/uClibc_dev/
BR2_CONFIGURE_STAGING_SYSROOT=--with-sysroot=$(STAGING_DIR)
BR2_CONFIGURE_BUILD_TOOLS=--with-build-time-tools=$(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin
-BR2_SYSROOT=--sysroot=$(STAGING_DIR)/
-BR2_ISYSROOT=-isysroot $(STAGING_DIR)
# gcc has a bunch of needed stuff....
include toolchain/gcc/Makefile.in