summaryrefslogtreecommitdiff
path: root/toolchain/binutils/binutils.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-12-06 16:40:07 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-27 22:00:59 +0100
commit21f7b8bccec20702170d89ab662757945d9ffbe9 (patch)
tree52d3d22344482e2b49cc66df2c178cea036c30df /toolchain/binutils/binutils.mk
parent6908149bec720e6bb4c2d1e8d03331bcd4e3343b (diff)
gmp: make it a proper package and bump to version 5.0.1
* Convert gmp to a proper autotargets package * Bump to version 5.0.1 * Hook it up for binutils/gcc to use Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/binutils/binutils.mk')
-rw-r--r--toolchain/binutils/binutils.mk12
1 files changed, 5 insertions, 7 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index ef9f64404..327a0f65d 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -16,17 +16,15 @@ endif
BINUTILS_HOST_PREREQ:=
BINUTILS_TARGET_PREREQ:=
-BINUTILS_HOST_PREREQ:=$(TOOLCHAIN_DIR)/gmp/lib/libgmp$(HOST_LIBEXT) \
- $(TOOLCHAIN_DIR)/mpfr/lib/libmpfr$(HOST_LIBEXT)
-HOST_SOURCE += host-libgmp-source host-libmpfr-source
+BINUTILS_HOST_PREREQ:=host-gmp $(TOOLCHAIN_DIR)/mpfr/lib/libmpfr$(HOST_LIBEXT)
+HOST_SOURCE += host-gmp-source host-libmpfr-source
-BINUTILS_TARGET_PREREQ:=$(TARGET_DIR)/usr/lib/libgmp$(LIBTGTEXT) \
- $(TARGET_DIR)/usr/lib/libmpfr$(LIBTGTEXT)
+BINUTILS_TARGET_PREREQ:=gmp $(TARGET_DIR)/usr/lib/libmpfr$(LIBTGTEXT)
-EXTRA_BINUTILS_CONFIG_OPTIONS+=--with-gmp="$(GMP_HOST_DIR)"
+EXTRA_BINUTILS_CONFIG_OPTIONS+=--with-gmp=$(HOST_DIR)/usr
EXTRA_BINUTILS_CONFIG_OPTIONS+=--with-mpfr="$(MPFR_HOST_DIR)"
-BINUTILS_TARGET_CONFIG_OPTIONS=--with-gmp="$(GMP_TARGET_DIR)"
+BINUTILS_TARGET_CONFIG_OPTIONS=--with-gmp=$(STAGING_DIR)/usr
BINUTILS_TARGET_CONFIG_OPTIONS+=--with-mpfr="$(MPFR_TARGET_DIR)"
ifeq ($(BR2_PACKAGE_LIBMPC),y)