summaryrefslogtreecommitdiff
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-12-06 16:40:09 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-27 22:00:59 +0100
commita6337a4dc81de8a9428860365a11a392baca323f (patch)
tree23538f8924715613d575385038fa8d10b6ecc5e3 /toolchain/binutils
parenteb8390d66f487559828058a47414617632afb1f1 (diff)
mpfr: make it a proper package and bump to version 3.0.0-p8
* Convert mpfr to a proper autotargets package * Bump to version 3.0.0-p8 * Hook it up for binutils/gcc to use Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/binutils.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index 327a0f65d..c33259057 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -16,16 +16,16 @@ endif
BINUTILS_HOST_PREREQ:=
BINUTILS_TARGET_PREREQ:=
-BINUTILS_HOST_PREREQ:=host-gmp $(TOOLCHAIN_DIR)/mpfr/lib/libmpfr$(HOST_LIBEXT)
-HOST_SOURCE += host-gmp-source host-libmpfr-source
+BINUTILS_HOST_PREREQ:=host-gmp host-mpfr
+HOST_SOURCE += host-gmp-source host-mpfr-source
-BINUTILS_TARGET_PREREQ:=gmp $(TARGET_DIR)/usr/lib/libmpfr$(LIBTGTEXT)
+BINUTILS_TARGET_PREREQ:=gmp mpfr
EXTRA_BINUTILS_CONFIG_OPTIONS+=--with-gmp=$(HOST_DIR)/usr
-EXTRA_BINUTILS_CONFIG_OPTIONS+=--with-mpfr="$(MPFR_HOST_DIR)"
+EXTRA_BINUTILS_CONFIG_OPTIONS+=--with-mpfr=$(HOST_DIR)/usr
BINUTILS_TARGET_CONFIG_OPTIONS=--with-gmp=$(STAGING_DIR)/usr
-BINUTILS_TARGET_CONFIG_OPTIONS+=--with-mpfr="$(MPFR_TARGET_DIR)"
+BINUTILS_TARGET_CONFIG_OPTIONS+=--with-mpfr=$(STAGING_DIR)/usr
ifeq ($(BR2_PACKAGE_LIBMPC),y)
BINUTILS_ADD_MPC = y