summaryrefslogtreecommitdiff
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-19 15:43:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-19 15:43:03 +0000
commitf336cfc9dba41ab854183680d6ccd30e0cb77157 (patch)
tree4ce796bbde9cee174d419402270be7623da8cbd8 /toolchain/binutils
parentc71b9520a6ade2c5432879bc7606f7afc6ff6d65 (diff)
use which to locate apps (useful for non-Linux systems like OS X)
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/binutils.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index cdb5f823d..9841278cf 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -58,15 +58,15 @@ $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld: $(BINUTILS_DIR1)/binutils/objdump
$(MAKE) -C $(BINUTILS_DIR1) install
binutils-dependancies:
- @if [ ! -x /usr/bin/bison ] ; then \
+ @if ! which bison ; then \
echo -e "\n\nYou must install 'bison' on your build machine\n"; \
exit 1; \
fi;
- @if [ ! -x /usr/bin/flex ] ; then \
+ @if ! which flex ; then \
echo -e "\n\nYou must install 'flex' on your build machine\n"; \
exit 1; \
fi;
- @if [ ! -x /usr/bin/msgfmt ] ; then \
+ @if ! which msgfmt ; then \
echo -e "\n\nYou must install 'gettext' on your build machine\n"; \
exit 1; \
fi;