summaryrefslogtreecommitdiff
path: root/toolchain/ccache
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /toolchain/ccache
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'toolchain/ccache')
-rw-r--r--toolchain/ccache/Makefile.in6
-rw-r--r--toolchain/ccache/ccache.mk11
2 files changed, 11 insertions, 6 deletions
diff --git a/toolchain/ccache/Makefile.in b/toolchain/ccache/Makefile.in
deleted file mode 100644
index fe859da30..000000000
--- a/toolchain/ccache/Makefile.in
+++ /dev/null
@@ -1,6 +0,0 @@
-ifeq ($(strip $(BR2_CCACHE)),y)
-TARGETS+=ccache
-endif
-ifeq ($(strip $(BR2_PACKAGE_CCACHE_TARGET)),y)
-TARGETS+=ccache_target
-endif
diff --git a/toolchain/ccache/ccache.mk b/toolchain/ccache/ccache.mk
index e2fdd71cc..71dfcde69 100644
--- a/toolchain/ccache/ccache.mk
+++ b/toolchain/ccache/ccache.mk
@@ -149,3 +149,14 @@ ccache_target-clean:
ccache_target-dirclean:
rm -rf $(CCACHE_DIR2)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_CCACHE)),y)
+TARGETS+=ccache
+endif
+ifeq ($(strip $(BR2_PACKAGE_CCACHE_TARGET)),y)
+TARGETS+=ccache_target
+endif