summaryrefslogtreecommitdiff
path: root/toolchain/dependencies/dependencies.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-24 15:57:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-24 17:48:26 +0100
commit960d268b25f61c407056c2eba946612a38d7de9f (patch)
tree3632fbf42a6a99fef49ba08766a1530df4da69e0 /toolchain/dependencies/dependencies.mk
parentac294cf557f0d6053373d9af3471300a12f28d1c (diff)
infrastructure: only require download tools when needed
Instead of having to require svn, git or bzr unconditionally, only require them when one package needs them to be downloaded. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/dependencies/dependencies.mk')
-rw-r--r--toolchain/dependencies/dependencies.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/dependencies/dependencies.mk b/toolchain/dependencies/dependencies.mk
index 89ffd8823..13604f092 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/toolchain/dependencies/dependencies.mk
@@ -10,9 +10,16 @@ ifeq ($(BR2_STRIP_sstrip),y)
DEPENDENCIES_HOST_PREREQ+=sstrip_host
endif
+# Remove duplicate entries from $(DL_TOOLS_DEPENDENCIES)
+DL_TOOLS = \
+ $(findstring svn,$(DL_TOOLS_DEPENDENCIES)) \
+ $(findstring git,$(DL_TOOLS_DEPENDENCIES)) \
+ $(findstring bzr,$(DL_TOOLS_DEPENDENCIES))
+
dependencies: $(DEPENDENCIES_HOST_PREREQ)
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
CONFIG_FILE="$(CONFIG_DIR)/.config" \
+ DL_TOOLS="$(DL_TOOLS)" \
$(TOPDIR)/toolchain/dependencies/dependencies.sh
dependencies-source: