summaryrefslogtreecommitdiff
path: root/toolchain/elf2flt
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-03-30 17:18:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-03-30 17:19:59 +0200
commitf220498f4b96c86b2d4ef7048f9c82f85c73d75c (patch)
tree14307b9a13979741e4b6b1e927bc1ffa91bc8da7 /toolchain/elf2flt
parent8628082b83110acad71c27b79edd5f5345c405b0 (diff)
get rid of broken nios2 support
Has been marked as broken for more than 1 year, with no indication that anyone cares, and it needs a bunch of special handling. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/elf2flt')
-rw-r--r--toolchain/elf2flt/elf2flt.mk5
-rw-r--r--toolchain/elf2flt/elf2flt.nios2.conditional47
2 files changed, 0 insertions, 52 deletions
diff --git a/toolchain/elf2flt/elf2flt.mk b/toolchain/elf2flt/elf2flt.mk
index d80a27765..7fecf3ea8 100644
--- a/toolchain/elf2flt/elf2flt.mk
+++ b/toolchain/elf2flt/elf2flt.mk
@@ -14,11 +14,6 @@ $(ELF2FLT_DIR)/.unpacked:
touch $@
$(ELF2FLT_DIR)/.patched: $(ELF2FLT_DIR)/.unpacked
-ifeq ($(strip $(ARCH)),nios2)
- $(SED) "s,STAGING_DIR,$(STAGING_DIR),g;" toolchain/elf2flt/elf2flt.nios2.conditional
- $(SED) "s,CROSS_COMPILE_PREFIX,$(REAL_GNU_TARGET_NAME),g;" toolchain/elf2flt/elf2flt.nios2.conditional
- toolchain/patch-kernel.sh $(ELF2FLT_DIR) toolchain/elf2flt elf2flt.nios2.conditional
-endif
$(CONFIG_UPDATE) $(@D)
touch $@
diff --git a/toolchain/elf2flt/elf2flt.nios2.conditional b/toolchain/elf2flt/elf2flt.nios2.conditional
deleted file mode 100644
index 96a3a9710..000000000
--- a/toolchain/elf2flt/elf2flt.nios2.conditional
+++ /dev/null
@@ -1,47 +0,0 @@
---- elf2flt/elf2flt.ld
-+++ elf2flt/elf2flt.ld
-@@ -63,12 +63,16 @@
- *(.eh_frame)
- *(.gcc_except_table)
-
-+ /* nios2 need gp */
-+ _gp = ABSOLUTE(ALIGN(16) + 0x7ff0);
-+ PROVIDE(gp = _gp);
-+
- /* Microblaze has .sdata and .sbss (small bss). They must
- be contiguous, so please don't move any of this. JW */
- _ssrw = . ;
- *(.sdata)
- *(.sdata.*)
-- *(.sbss) /* Don't move this! */
-+ *(.sbss .gnu.linkonce.sb*) /* Don't move this! */
- _essrw = . ;
-
- _ssrw_size = _essrw - _ssrw;
-@@ -176,4 +180,6 @@
- .debug_line 0 : { *(.debug_line) }
- .debug_pubnames 0 : { *(.debug_pubnames) }
- .debug_aranges 0 : { *(.debug_aranges) }
-+ .debug_frame 0 : { *(.debug_frame) }
-+ .debug_str 0 : { *(.debug_str) }
- }
---- elf2flt/ld-elf2flt.in
-+++ elf2flt/ld-elf2flt.in
-@@ -132,7 +132,7 @@
- esac
- ARG1="$ARG1 -defsym $GOT_OFFSET=`expr ${SHARED_ID} '*' -4 - 4`"
- fi
-- if [ "@emit_relocs@" = "yes" ]
-+ if [ "no" = "yes" ]
- then
- SEDOP="$SEDOP -e s/^SINGLE_LINK://"
- else
-@@ -155,7 +155,7 @@
- LDSCRIPT="$NEWLDSCRIPT"
- fi
-
-- if [ "@emit_relocs@" = "yes" ]
-+ if [ "no" = "yes" ]
- then
- $LINKER $EMUL $SDIRS -T $LDSCRIPT -q -o "$OFILE.gdb" $ARG1 ||exit $?
- RFILE="$OFILE.gdb"