summaryrefslogtreecommitdiff
path: root/toolchain/external-toolchain/ext-tool.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-21 20:30:28 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-21 20:30:28 +0200
commitc89b725978616a24e066e6b01030bdd3fc0ab5c0 (patch)
treec869c538c6d0b7b7c702ef7c24c4c59a89a973b2 /toolchain/external-toolchain/ext-tool.mk
parent319a4751c4a3a0209f628a7470a6d8e400d3479d (diff)
parent52e600ebec9cb571edee8f791da851035ae6b969 (diff)
Merge branch '2010-05-15-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'toolchain/external-toolchain/ext-tool.mk')
-rw-r--r--toolchain/external-toolchain/ext-tool.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 2c2562cde..bb4809ccd 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -232,6 +232,15 @@ check_arm_abi = \
fi ; \
#
+# Check that the external toolchain supports C++
+#
+check_cplusplus = \
+ if ! test -x $(TARGET_CXX) ; then \
+ echo "BR2_INSTALL_LIBSTDCPP is selected but C++ support not available in external toolchain" ; \
+ exit 1 ; \
+ fi ; \
+
+#
# Check that the cross-compiler given in the configuration exists
#
check_cross_compiler_exists = \
@@ -288,6 +297,9 @@ endif
ifeq ($(BR2_arm),y)
$(Q)$(call check_arm_abi)
endif
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ $(Q)$(call check_cplusplus)
+endif
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
$(Q)$(call check_uclibc,$(SYSROOT_DIR))
else