summaryrefslogtreecommitdiff
path: root/toolchain/external-toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-11-03 10:37:27 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-11-03 10:37:27 +0000
commit030a9d39b1754d7d9750308202686db8b5c929d7 (patch)
tree289add222d4e74ae4d45a98f6fb1ba313a0f8150 /toolchain/external-toolchain
parentdf1df36fcbdb14d96e94198714ef0e8c990f8d17 (diff)
External toolchain C++ cross-compiler fix
External toolchain C++ cross-compiler fix package/Makefile.in resets CXX to "" in TARGET_CONFIGURE_OPTS if BR2_GCC_CROSS_CXX is not set to 'y'. However, when using an external toolchain, BR2_GCC_CROSS_CXX is not set even if the toolchain has a C++ cross-compiler. This patch adds a new BR2_GCC_CROSS_CXX option in the external toolchain configuration menu, so that just like BR2_INET_RPC, BR2_INET_IPV6 and the others, it can be set according to the external toolchain configuration. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/external-toolchain')
-rw-r--r--toolchain/external-toolchain/Config.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/external-toolchain/Config.in b/toolchain/external-toolchain/Config.in
index 805d21a2c..6c957bc9b 100644
--- a/toolchain/external-toolchain/Config.in
+++ b/toolchain/external-toolchain/Config.in
@@ -93,6 +93,12 @@ config BR2_SOFT_FLOAT
help
Set this option if the external toolchain supports soft float.
+config BR2_GCC_CROSS_CXX
+ bool "Toolchain has C++ cross-compiler ?"
+ help
+ Set this option if the external toolchain has a C++
+ cross-compiler.
+
config BR2_TARGET_OPTIMIZATION
string "Target Optimizations"
default "-Os -pipe"