summaryrefslogtreecommitdiff
path: root/toolchain/gcc/4.0.0/602-sdk-libstdc++-includes.patch
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2005-04-30 22:01:20 +0000
committerManuel Novoa III <mjn3@codepoet.org>2005-04-30 22:01:20 +0000
commit71afd3a1a03df8a311e3d683d3b6d8fccf2443dc (patch)
treed10ea7f9962f075c5051a8da588987f7c02b7d02 /toolchain/gcc/4.0.0/602-sdk-libstdc++-includes.patch
parent3e0abd14cfd49c640411b0f57f7f995132c1feff (diff)
Add 4.0.0 support. Some arches may still need some tweaking and/or additional patches. But I successfully built cross and target toolchains for x86 and mipsel supporting c/c++/objective-c/java. Of course I haven't tested them yet...
Diffstat (limited to 'toolchain/gcc/4.0.0/602-sdk-libstdc++-includes.patch')
-rw-r--r--toolchain/gcc/4.0.0/602-sdk-libstdc++-includes.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/toolchain/gcc/4.0.0/602-sdk-libstdc++-includes.patch b/toolchain/gcc/4.0.0/602-sdk-libstdc++-includes.patch
new file mode 100644
index 000000000..c7676ae6a
--- /dev/null
+++ b/toolchain/gcc/4.0.0/602-sdk-libstdc++-includes.patch
@@ -0,0 +1,22 @@
+diff -urN gcc-4.0.0-100/libstdc++-v3/fragment.am gcc-4.0.0/libstdc++-v3/fragment.am
+--- gcc-4.0.0-100/libstdc++-v3/fragment.am 2004-10-25 15:32:40.000000000 -0500
++++ gcc-4.0.0/libstdc++-v3/fragment.am 2005-04-28 21:48:43.000000000 -0500
+@@ -18,5 +18,5 @@
+ $(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
+
+ # -I/-D flags to pass when compiling.
+-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
++AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
+
+diff -urN gcc-4.0.0-100/libstdc++-v3/libmath/Makefile.am gcc-4.0.0/libstdc++-v3/libmath/Makefile.am
+--- gcc-4.0.0-100/libstdc++-v3/libmath/Makefile.am 2003-08-27 16:29:42.000000000 -0500
++++ gcc-4.0.0/libstdc++-v3/libmath/Makefile.am 2005-04-28 21:48:43.000000000 -0500
+@@ -32,7 +32,7 @@
+
+ libmath_la_SOURCES = stubs.c
+
+-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
++AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
+
+ # Only compiling "C" sources in this directory.
+ LIBTOOL = @LIBTOOL@ --tag CC