summaryrefslogtreecommitdiff
path: root/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2005-04-28 03:53:52 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2005-04-28 03:53:52 +0000
commit8a5d57bbb2aacabb29f6ac031cc4263a0f5404cf (patch)
treefe8e5e5d7cad96f6b7a0d39a331fbb326a1c7e67 /toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch
parent719bb81a16ea34600664900b2d3fc63df5cc10d0 (diff)
Add support for soon to be released binutils-2.16 as well as
GCC-4.1.0. These tool versions are needed so that NPTL support can be added into uClibc. Backporting NPTL from GCC-4.1.0 into GCC-4.0 may be possible, but not recommended.
Diffstat (limited to 'toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch')
-rw-r--r--toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch b/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch
new file mode 100644
index 000000000..23fce7544
--- /dev/null
+++ b/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch
@@ -0,0 +1,20 @@
+--- gcc-4.1.0/libstdc++-v3/fragment.am 2005-03-21 11:40:14.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/fragment.am 2005-04-25 20:14:39.856251785 -0500
+@@ -21,5 +21,5 @@
+ $(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
+
+ # -I/-D flags to pass when compiling.
+-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
++AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
+
+--- gcc-4.1.0/libstdc++-v3/libmath/Makefile.am 2005-03-21 11:40:18.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/libmath/Makefile.am 2005-04-25 20:14:39.682280735 -0500
+@@ -35,7 +35,7 @@
+
+ libmath_la_SOURCES = stubs.c
+
+-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
++AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
+
+ # Only compiling "C" sources in this directory.
+ LIBTOOL = @LIBTOOL@ --tag CC