summaryrefslogtreecommitdiff
path: root/toolchain/gcc/4.2/602-sdk-libstdc++-includes.patch
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-13 05:50:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-13 05:50:37 +0000
commitff6ca6a7107fd884fcb2e5292dfcaaa0b432aafc (patch)
treeb3fd175ea8cdd0272f3556889187bfb107d4b567 /toolchain/gcc/4.2/602-sdk-libstdc++-includes.patch
parent7528aaa923b78deaf5727c22d6b114bd1f2e6929 (diff)
since 4.2.0 isnt actually out, rename patchdir to match new snapshot support
Diffstat (limited to 'toolchain/gcc/4.2/602-sdk-libstdc++-includes.patch')
-rw-r--r--toolchain/gcc/4.2/602-sdk-libstdc++-includes.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/toolchain/gcc/4.2/602-sdk-libstdc++-includes.patch b/toolchain/gcc/4.2/602-sdk-libstdc++-includes.patch
new file mode 100644
index 000000000..23fce7544
--- /dev/null
+++ b/toolchain/gcc/4.2/602-sdk-libstdc++-includes.patch
@@ -0,0 +1,20 @@
+--- gcc-4.1.0/libstdc++-v3/fragment.am 2005-03-21 11:40:14.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/fragment.am 2005-04-25 20:14:39.856251785 -0500
+@@ -21,5 +21,5 @@
+ $(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
+
+ # -I/-D flags to pass when compiling.
+-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
++AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
+
+--- gcc-4.1.0/libstdc++-v3/libmath/Makefile.am 2005-03-21 11:40:18.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/libmath/Makefile.am 2005-04-25 20:14:39.682280735 -0500
+@@ -35,7 +35,7 @@
+
+ libmath_la_SOURCES = stubs.c
+
+-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
++AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
+
+ # Only compiling "C" sources in this directory.
+ LIBTOOL = @LIBTOOL@ --tag CC