summaryrefslogtreecommitdiff
path: root/toolchain/gcc/Makefile.in
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-07-18 23:34:20 +0000
committerEric Andersen <andersen@codepoet.org>2005-07-18 23:34:20 +0000
commitbd7ed099dc120ca602006eb18705f7caa394e36d (patch)
tree3e238c643164e845a78a62f76b9c43f366f399a5 /toolchain/gcc/Makefile.in
parent58f2a53ffbe96f976dc431407db687aa7e38842a (diff)
Apply the fix for gcc bug #22167
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=22167 remove gcc 3.3.3, change config for sjlj exception handling a bit.
Diffstat (limited to 'toolchain/gcc/Makefile.in')
-rw-r--r--toolchain/gcc/Makefile.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 908a45276..11733c95c 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -6,14 +6,15 @@
GCC_VERSION:=$(strip $(subst ",, $(BR2_GCC_VERSION)))
#"
-GCC_USE_SJLJ_EXCEPTIONS:=$(strip $(subst ",, $(BR2_GCC_USE_SJLJ_EXCEPTIONS)))
-#"
TARGET_OPTIMIZATION:=$(strip $(subst ",, $(BR2_TARGET_OPTIMIZATION)))
#"
EXTRA_GCC_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_GCC_CONFIG_OPTIONS)))
#"
+ifeq ($(strip $(BR2_GCC_USE_SJLJ_EXCEPTIONS)),y)
+GCC_USE_SJLJ_EXCEPTIONS:=--enable-sjlj-exceptions
+endif
ifeq ($(BR2_SOFT_FLOAT),y)
# gcc 3.4.x soft float configuration is different than previous versions.
ifeq ($(findstring 3.4.,$(GCC_VERSION)),3.4.)
@@ -39,3 +40,4 @@ endif
ifeq ($(strip $(BR2_PACKAGE_GCC_TARGET)),y)
TARGETS+=gcc_target
endif
+