summaryrefslogtreecommitdiff
path: root/toolchain/gcc/Makefile.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-12-04 20:34:03 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-04 20:34:03 +0100
commitacc75665e54bc505f46a4f8ce09c0c6634f74b91 (patch)
treeddb4fbf1fd10e4412d9723186731815532730139 /toolchain/gcc/Makefile.in
parentba4183bc827bd2bcc85a97e4029dfd8c903420fd (diff)
toolchain: get rid of unused gcc 3.x legacy handling
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc/Makefile.in')
-rw-r--r--toolchain/gcc/Makefile.in17
1 files changed, 0 insertions, 17 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index e052b83b4..e92ecbc7b 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -19,17 +19,6 @@ GCC_USE_SJLJ_EXCEPTIONS:=--enable-sjlj-exceptions
endif
ifeq ($(BR2_SOFT_FLOAT),y)
-# gcc 3.4.x soft float configuration is different than previous versions.
-ifeq ($(findstring x3.4.,x$(GCC_VERSION)),x3.4.)
-ifneq ($(BR2_nios2),y)
-SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
-endif
-else
-SOFT_FLOAT_CONFIG_OPTION:=--without-float
-endif
-
-# again... there must be a better way
-ifeq ($(findstring x4.,x$(GCC_VERSION)),x4.)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
ifeq ($(BR2_SOFT_FLOAT_FP),y)
TARGET_SOFT_FLOAT:=-mfloat-abi=softfp
@@ -40,9 +29,6 @@ else
TARGET_SOFT_FLOAT:=-msoft-float
endif
endif
-else # not gcc-4.x
-TARGET_SOFT_FLOAT:=-msoft-float
-endif
ARCH_FPU_SUFFIX:=_nofpu
else # no softfloat support
SOFT_FLOAT_CONFIG_OPTION:=
@@ -89,10 +75,7 @@ endif
EXTRA_TARGET_GCC_CONFIG_OPTIONS+=$(call qstrip,$(BR2_EXTRA_TARGET_GCC_CONFIG_OPTIONS))
ifeq ($(BR2_PREFER_IMA),y)
-# >= 4.x
-ifneq ($(findstring x3.,x$(GCC_VERSION)),x3.)
EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--enable-intermodule
-endif
endif # BR2_PREFER_IMA=y
TARGETS+=gcc_target