summaryrefslogtreecommitdiff
path: root/toolchain/gcc/Makefile.in
diff options
context:
space:
mode:
authorKonrad Eisele <konrad@gaisler.com>2010-11-09 13:27:37 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-25 09:15:11 +0100
commitc9f1651ea04bd0fcdb49275e3cae7fa2431a5379 (patch)
treeb2c723a2287e601dce0855b0260e2a3906b0327d /toolchain/gcc/Makefile.in
parentfe629f97d84c1444e47152f73b4f3e1c1a3ec56d (diff)
toolchain: Add support for --with-cpu
Add support for gcc configuration switch --with-cpu. Uses newly added BR2_GCC_TARGET_CPU from the target config. Signed-off-by: Konrad Eisele <konrad@gaisler.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc/Makefile.in')
-rw-r--r--toolchain/gcc/Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index b6ebca902..2e55ed0f7 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -37,6 +37,9 @@ endif
ifneq ($(call qstrip,$(BR2_GCC_TARGET_ABI)),)
GCC_WITH_ABI:=--with-abi=$(BR2_GCC_TARGET_ABI)
endif
+ifneq ($(call qstrip,$(BR2_GCC_TARGET_CPU)),)
+GCC_WITH_CPU:=--with-cpu=$(BR2_GCC_TARGET_CPU)
+endif
# AVR32 GCC configuration
ifeq ($(BR2_avr32),y)