summaryrefslogtreecommitdiff
path: root/toolchain/gcc/gcc-uclibc-3.x.mk
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-06 18:14:00 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-06 18:14:00 +0000
commitc6eb2ed657f6c91d021baf5926b4bd14066667be (patch)
treedfcd378acdd52c6599de17d586290f247d8eb6dd /toolchain/gcc/gcc-uclibc-3.x.mk
parent3342c8c547f9b1acacaec803262adf786a7f0981 (diff)
- adjust to use the gcc-4.2.0 release
- adjust default gdb version to 6.6 - fix stripping gmp/mpfr due to recent LIBTGTEXT changes
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-3.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk12
1 files changed, 8 insertions, 4 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index e95e49ee2..8d6de7ed3 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -36,13 +36,17 @@ GCC_STRIP_HOST_BINARIES:=true
ifeq ($(findstring 3.,$(GCC_VERSION)),3.)
GCC_NO_MPFR:=y
-endif
+else
+ifneq ($(BR2_INSTALL_FORTRAN),y)
+# fortran needs gmp and mpfr
ifeq ($(findstring 4.0.,$(GCC_VERSION)),4.0.)
GCC_NO_MPFR:=y
endif
-#ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
-#GCC_NO_MPFR:=y
-#endif
+ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
+GCC_NO_MPFR:=y
+endif
+endif
+endif
#############################################################
#