summaryrefslogtreecommitdiff
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-02 07:43:01 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-02 09:13:30 +0200
commit52b8d0478a28d5c8bb29983ad9527e0fa5fae528 (patch)
treead8db6dd14d0aa0377917216c2e64f244d961618 /toolchain/gcc/gcc-uclibc-4.x.mk
parent3404ad7c4fd5997ba7becf239ab8bc5b919393aa (diff)
toolchain: remove unused special detection of old toolchains
We only support gcc >= 4.2.x for the internal toolchain. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk30
1 files changed, 1 insertions, 29 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 6cede5ea3..081e906c8 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -37,10 +37,6 @@ GCC_CAT:=$(BZCAT)
GCC_STRIP_HOST_BINARIES:=nope
GCC_SRC_DIR:=$(GCC_DIR)
-ifeq ($(findstring x4.0.,x$(GCC_VERSION)),x4.0.)
-GCC_NO_MPFR:=y
-endif
-
# Branding works on >= 4.3
ifneq ($(findstring x4.2.,x$(GCC_VERSION)),x4.2.)
BUILDROOT_VERSION_STRING=$(call qstrip,$(BR2_VERSION))
@@ -101,7 +97,6 @@ ifeq ($(BR2_INSTALL_OBJC),y)
GCC_TARGET_LANGUAGES:=$(GCC_TARGET_LANGUAGES),objc
endif
-ifndef GCC_NO_MPFR
GCC_WITH_HOST_GMP=--with-gmp=$(GMP_HOST_DIR)
GCC_WITH_HOST_MPFR=--with-mpfr=$(MPFR_HOST_DIR)
HOST_SOURCE += host-libgmp-source host-libmpfr-source
@@ -113,7 +108,6 @@ GCC_TARGET_LANGUAGES:=$(GCC_TARGET_LANGUAGES),fortran
GCC_WITH_TARGET_GMP=--with-gmp="$(GMP_TARGET_DIR)"
GCC_WITH_TARGET_MPFR=--with-mpfr="$(MPFR_TARGET_DIR)"
endif
-endif # ifndef GCC_NO_MPFR
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
GCC_SHARED_LIBGCC:=--enable-shared
@@ -433,32 +427,10 @@ $(GCC_BUILD_DIR3)/.compiled: $(GCC_BUILD_DIR3)/.configured
$(MAKE) -C $(GCC_BUILD_DIR3) all
touch $@
-#
-# gcc-lib dir changes names to gcc with 3.4.mumble
-#
-GCC_LIB_SUBDIR=lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
-# sigh... we need to find a better way
-ifeq ($(findstring x4.0.,x$(GCC_VERSION)),x4.0.)
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
-endif
-ifeq ($(findstring x4.1.,x$(GCC_VERSION)),x4.1.)
-GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
-endif
ifeq ($(findstring x4.2,x$(GCC_VERSION)),x4.2)
-ifneq ($(findstring x4.2.,x$(GCC_VERSION)),x4.2.)
-REAL_GCC_VERSION=$(shell cat $(GCC_SRC_DIR)/gcc/BASE-VER)
-GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(REAL_GCC_VERSION)
-else
-GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
-endif
-endif
GCC_INCLUDE_DIR:=include
-ifeq ($(findstring x4.3,x$(GCC_VERSION)),x4.3)
-GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
-GCC_INCLUDE_DIR:=include-fixed
-endif
-ifeq ($(findstring x4.4,x$(GCC_VERSION)),x4.4)
-GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
+else
GCC_INCLUDE_DIR:=include-fixed
endif