summaryrefslogtreecommitdiff
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-11-03 16:08:21 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-04 20:16:28 +0100
commitaa3e75ecd1a2cf0a00d44f13e6f6a6adc7e97cc2 (patch)
tree1b0088d3a1c8cf02f5363ca20ac155946b442144 /toolchain/gcc/gcc-uclibc-4.x.mk
parent1310bad0aee3254266976cc68c70032da5405a34 (diff)
gcc 4.5.x powerpc: fix softfloat and gcc pr#43810
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk16
1 files changed, 13 insertions, 3 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 7e3ee49ff..684dca8e9 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -43,6 +43,16 @@ EXTRA_GCC_CONFIG_OPTIONS+=--with-pkgversion="Buildroot $(BR2_VERSION_FULL)" \
--with-bugurl="http://bugs.buildroot.net/"
endif
+# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43810
+# Workaround until it's fixed in 4.5.2 or later
+ifeq ($(ARCH),powerpc)
+ifeq ($(findstring x4.5.,x$(GCC_VERSION)),x4.5.)
+GCC_OPTSPACE=--disable-target-optspace
+endif
+else
+GCC_OPTSPACE=--enable-target-optspace
+endif
+
GCC_TARGET_PREREQ=
GCC_STAGING_PREREQ=
@@ -204,7 +214,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
--enable-languages=c \
$(BR2_CONFIGURE_DEVEL_SYSROOT) \
--disable-__cxa_atexit \
- --enable-target-optspace \
+ $(GCC_OPTSPACE) \
--with-gnu-ld \
--disable-shared \
--disable-libssp \
@@ -282,7 +292,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched
--enable-languages=c \
$(BR2_CONFIGURE_DEVEL_SYSROOT) \
--disable-__cxa_atexit \
- --enable-target-optspace \
+ $(GCC_OPTSPACE) \
--with-gnu-ld \
--enable-shared \
--disable-libssp \
@@ -359,7 +369,7 @@ $(GCC_BUILD_DIR3)/.configured: $(GCC_SRC_DIR)/.patched $(GCC_STAGING_PREREQ)
$(BR2_CONFIGURE_STAGING_SYSROOT) \
$(BR2_CONFIGURE_BUILD_TOOLS) \
--disable-__cxa_atexit \
- --enable-target-optspace \
+ $(GCC_OPTSPACE) \
--with-gnu-ld \
--disable-libssp \
--disable-multilib \