summaryrefslogtreecommitdiff
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-27 18:17:26 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-27 18:23:16 +0200
commitf43054d841c82c121c4fd8c1e6604888233b6d10 (patch)
tree5035796c0d006d5c7b62c5aad13b2e0812eb8eb4 /toolchain/gcc/gcc-uclibc-4.x.mk
parent5e8e1cdb608499dc620d88af32033adca72e5645 (diff)
target-gcc: fix build
Now that $(STAGING_DIR)/usr/bin is no longer in the PATH, we need to pass the absolute paths to $(TARGET_CC) when building the target gcc compiler. This commit fixes the target gcc build problem reported on the list. I have successfully been able to build a target gcc for ARM, use it to compile a hello world application on the target and run this application. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index cfbe6164d..52b20e959 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -397,6 +397,8 @@ $(GCC_BUILD_DIR3)/.configured: $(GCC_BUILD_DIR3)/.prepared
CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
BOOT_CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
+ GCC_FOR_TARGET="$(TARGET_CC)" \
+ CC_FOR_TARGET="$(TARGET_CC)" \
$(GCC_SRC_DIR)/configure $(QUIET) \
--prefix=/usr \
--build=$(GNU_HOST_NAME) \