summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-05-02 17:38:27 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-02 23:12:30 +0200
commit1db3939ad91e88d420bc8983b4708ee65d3c91e2 (patch)
tree0019b35ce889f8439fa7e4cf14437a979bcd2998 /toolchain/gcc
parent28cdaaee5236d0cbe3a6afde808f5eef260e7c33 (diff)
toolchain: update gcc snapshot version
* Make mpc mandatory since we are probably building bleeding-edge * Change snapshot naming convention to match the source Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in12
-rw-r--r--toolchain/gcc/Config.in.22
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk11
3 files changed, 21 insertions, 4 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 437b86bb7..f11c80fab 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -45,11 +45,17 @@ config BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE
config BR2_GCC_SNAP_DATE
string "GCC snapshot date"
- default "20070921"
+ default "4.7-20110430"
depends on BR2_GCC_VERSION_SNAP
help
- Enter snapshot date to use for gcc. Format is:
- YYYYMMDD
+ Enter snapshot date to use for gcc.
+ Format is: A.B-YYYYMMDD
+
+ A is GCC major version, for example 4.
+ B is GCC minor version, for example 7.
+ YYYYMMDD is snapshot date, for example 20110430.
+
+ This way we'd get version 4.7-20110430
config BR2_GCC_VERSION
string
diff --git a/toolchain/gcc/Config.in.2 b/toolchain/gcc/Config.in.2
index 7a49068a7..c76d12583 100644
--- a/toolchain/gcc/Config.in.2
+++ b/toolchain/gcc/Config.in.2
@@ -3,7 +3,7 @@ config BR2_PACKAGE_GCC_TARGET
depends on BR2_HAVE_DEVFILES && BR2_TOOLCHAIN_BUILDROOT
select BR2_PACKAGE_BINUTILS
select BR2_PACKAGE_BINUTILS_TARGET
- select BR2_PACKAGE_MPC if (BR2_GCC_VERSION_4_5_X || BR2_GCC_VERSION_4_6_X)
+ select BR2_PACKAGE_MPC if (BR2_GCC_VERSION_4_5_X || BR2_GCC_VERSION_4_6_X || BR2_GCC_VERSION_SNAP)
select BR2_PACKAGE_MPFR
select BR2_PACKAGE_GMP
help
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 9b8bf685c..712361549 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -141,6 +141,17 @@ endif
GCC_HOST_PREREQ += host-mpc
endif
+# GCC snapshot prerequisites
+# Since we don't know and it can be quite new just ask for everything known
+ifneq ($(GCC_SNAP_DATE),)
+GCC_WITH_HOST_MPC = --with-mpc=$(HOST_DIR)/usr
+GCC_TARGET_PREREQ += mpc
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+HOST_SOURCE += host-mpc-source
+endif
+GCC_HOST_PREREQ += host-mpc
+endif
+
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
GCC_SHARED_LIBGCC:=--enable-shared
else