summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-04-13 13:29:28 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-04-26 22:43:44 +0200
commit243e4edc748b26f9a713bc268e5b7a6ff7d15956 (patch)
tree1ebf42c2f253943d60ac1ff61627aecf8262af8e /toolchain/gcc
parent4612aeec57ee5356a535727cf578e072649447ba (diff)
toolchain: make target gcc a working option
Make target gcc a more usable option. * Nuke duplicate libgcc_s*.so* in /usr/lib since it confuses target gcc * Copy *crt*.o files to the target system to unbreak gcc Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 96bebd616..04b21e9f1 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -550,12 +550,17 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR4)/.compiled
cp -f $(HOST_DIR)/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/syslimits.h \
$(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/; \
fi
+
# Make sure we have 'cc'.
if [ ! -e $(TARGET_DIR)/usr/bin/cc ]; then \
ln -snf gcc $(TARGET_DIR)/usr/bin/cc; \
fi
+
+ # Copy C runtime initialization object files
+ cp -f $(STAGING_DIR)/usr/lib/*crt*.o $(TARGET_DIR)/usr/lib
+
# These are in /lib, so...
- #rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
+ rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
touch -c $@
gcc_target: $(STAMP_DIR)/gcc_libs_target_installed $(GCC_TARGET_PREREQ) binutils $(TARGET_DIR)/usr/bin/gcc