summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-02-10 11:19:09 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-10 20:15:16 +0100
commit2a161016d734b7f50b0468554fd683756f328209 (patch)
tree23d50c616b143fd8749a17cff46b604b11a45bcc /toolchain/gcc
parent85a9a4d01ef26343c2266cefc2d8a635caff7362 (diff)
target gcc: fix recompilation issue
gcc_target wants uclibc_target which is now first stage uclibc (not real, from the NPTL build stage addition). This triggers gcc-final to be rebuilt (albeit cached) and reinstalled, thus touching all the stamps around and triggering a rebuild of gcc_target. Switch to $(STAMP_DIR)/gcc_libs_target_installed instead so that we only depend on the last stage of cross gcc being installed to rebuild. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 2c857dce5..96bebd616 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -558,7 +558,7 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR4)/.compiled
#rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
touch -c $@
-gcc_target: uclibc_target $(GCC_TARGET_PREREQ) binutils $(TARGET_DIR)/usr/bin/gcc
+gcc_target: $(STAMP_DIR)/gcc_libs_target_installed $(GCC_TARGET_PREREQ) binutils $(TARGET_DIR)/usr/bin/gcc
gcc_target-clean:
rm -rf $(GCC_BUILD_DIR4)