summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-27 22:32:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-27 22:32:02 +0200
commit454b70d03afd45a9f78976b93051c61b80ab245d (patch)
treeed1420f0a60eb843e44fd79c3d02098067330fc1 /toolchain/gcc
parentfed6a2a6ea884630a3723d2a49579e63e87ffd57 (diff)
target-g++: fix build
Just as we did to fix target-gcc, pass CXX_FOR_TARGET when building target g++, and remove useless copies of g++ and c++. Tested on ARM by compiling a simple C++ program using <iostream> on the target and running it. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 9720ed39b..6e767ac77 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -399,6 +399,7 @@ $(GCC_BUILD_DIR3)/.configured: $(GCC_BUILD_DIR3)/.prepared
BOOT_CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
GCC_FOR_TARGET="$(TARGET_CC)" \
CC_FOR_TARGET="$(TARGET_CC)" \
+ CXX_FOR_TARGET="$(TARGET_CXX)" \
$(GCC_SRC_DIR)/configure $(QUIET) \
--prefix=/usr \
--build=$(GNU_HOST_NAME) \
@@ -445,8 +446,10 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
# Remove broken specs file (cross compile flag is set).
rm -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/specs
- # Remove useless copies of gcc
+ # Remove useless copies of gcc, c++, g++
rm -f $(TARGET_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gcc*
+ rm -f $(TARGET_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-g++*
+ rm -f $(TARGET_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-c++*
# Work around problem of missing syslimits.h
if [ ! -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/syslimits.h ]; then \