summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-22 21:38:15 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-22 21:38:15 +0000
commit4909da41569ecf7a974b976646aa13222b0ee8ff (patch)
tree58b26841c198cdf71da5ce5413780bf6f5481599 /toolchain/gcc
parent4a52da0f34ce8d1f5267274cad3bd20f40062c78 (diff)
- rename the gcc base_target to the more appropriate term cross_compiler
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk4
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk4
2 files changed, 6 insertions, 2 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index d05de8f4b..bb34797be 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -350,7 +350,9 @@ ifeq ($(BR2_INSTALL_LIBGCJ),y)
endif
touch $@
-gcc: uclibc-configured binutils gcc_initial $(LIBFLOAT_TARGET) uclibc \
+cross_compiler:=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gcc
+cross_compiler gcc: uclibc-configured binutils gcc_initial \
+ $(LIBFLOAT_TARGET) uclibc \
$(GCC_BUILD_DIR2)/.installed $(GCC_BUILD_DIR2)/.libs_installed \
$(GCC_TARGETS)
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 1fd9b11d0..08303ee28 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -357,7 +357,9 @@ ifeq ($(BR2_INSTALL_LIBGCJ),y)
endif
touch $@
-gcc: uclibc-configured binutils gcc_initial $(LIBFLOAT_TARGET) uclibc \
+cross_compiler:=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gcc
+cross_compiler gcc: uclibc-configured binutils gcc_initial \
+ $(LIBFLOAT_TARGET) uclibc \
$(GCC_BUILD_DIR2)/.installed $(GCC_BUILD_DIR2)/.libs_installed \
$(GCC_TARGETS)