summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-28 12:02:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-28 17:38:31 +0200
commit6d4a992e2b817cc14276c68e0321edaf66450cf3 (patch)
tree3f792b98d112ca4a58cfd0d653d6d65fd395b8bd /toolchain/gcc
parent13a10a095949e4304f19ea3d5a78b2f3ce2bd6b6 (diff)
gcc: remove option on SJLJ exceptions
This is a very advanced option, and it seems, according to http://choices.cs.uiuc.edu/exceptions.pdf that SJLJ exceptions aren't really interesting. Users really interested by this can always use the BR2_EXTRA_GCC_CONFIG_OPTIONS is they want. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in8
-rw-r--r--toolchain/gcc/Makefile.in4
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk2
3 files changed, 0 insertions, 14 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 31eba6bfb..cbdc02699 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -68,14 +68,6 @@ config BR2_GCC_VERSION
default "4.4.4" if BR2_GCC_VERSION_4_4_X
default $BR2_GCC_SNAP_DATE if BR2_GCC_VERSION_SNAP
-config BR2_GCC_USE_SJLJ_EXCEPTIONS
- bool "Enable setjmp/longjmp exceptions?"
- help
- For some platforms, proper stack unwinding works perfectly,
- while other platforms must use setjmp/longjmp exceptions for
- proper stack unwinding during exception handling. Most people
- can leave this set to n.
-
config BR2_EXTRA_GCC_CONFIG_OPTIONS
string "Additional gcc options"
default ""
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 9537e9dc7..b6ebca902 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -13,10 +13,6 @@ else
GCC_SNAP_DATE:=
endif
-ifeq ($(BR2_GCC_USE_SJLJ_EXCEPTIONS),y)
-GCC_USE_SJLJ_EXCEPTIONS:=--enable-sjlj-exceptions
-endif
-
ifeq ($(BR2_SOFT_FLOAT),y)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
ifeq ($(BR2_arm)$(BR2_armeb),y) # only set float-abi for arm
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index dfc1790a9..d9269bd23 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -290,7 +290,6 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_SRC_DIR)/.patched $(GCC_STAGING_PREREQ)
$(GCC_DECIMAL_FLOAT) \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(GCC_WITH_ABI) $(GCC_WITH_ARCH) $(GCC_WITH_TUNE) \
- $(GCC_USE_SJLJ_EXCEPTIONS) \
$(DISABLE_LARGEFILE) \
$(EXTRA_GCC_CONFIG_OPTIONS) \
$(EXTRA_GCC2_CONFIG_OPTIONS) \
@@ -424,7 +423,6 @@ $(GCC_BUILD_DIR3)/.configured: $(GCC_BUILD_DIR3)/.prepared
$(GCC_DECIMAL_FLOAT) \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(GCC_WITH_ABI) $(GCC_WITH_ARCH) $(GCC_WITH_TUNE) \
- $(GCC_USE_SJLJ_EXCEPTIONS) \
$(DISABLE_LARGEFILE) \
$(EXTRA_GCC_CONFIG_OPTIONS) \
$(EXTRA_TARGET_GCC_CONFIG_OPTIONS) \