summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-12-31 08:39:06 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-02 22:55:37 +0100
commit81f1f99dc5e54f02fd09e8b5a152b7beba5dbec5 (patch)
treef5993697a7a94fae6de8939d9183e697c2fcb8d8 /toolchain/gcc
parent5ad139ebc9916413d25cfe1603da9aef89752231 (diff)
target gcc: cleanup
WITH_TARGET_{GMP/MPC/MPFR} is unneeded since we are providing a sysroot. It also breaks build-gcc under certain conditions. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk6
1 files changed, 0 insertions, 6 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 633b8aae8..80bed5eff 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -119,11 +119,8 @@ GCC_HOST_PREREQ += host-mpc
endif
GCC_TARGET_PREREQ += mpfr gmp
-GCC_WITH_TARGET_GMP = --with-gmp=$(STAGING_DIR)/usr
-GCC_WITH_TARGET_MPFR = --with-mpfr=$(STAGING_DIR)/usr
ifeq ($(findstring x4.5.,x$(GCC_VERSION)),x4.5.)
GCC_TARGET_PREREQ += mpc
-GCC_WITH_TARGET_MPC = --with-mpc=$(STAGING_DIR)/usr
endif
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
@@ -506,9 +503,6 @@ $(GCC_BUILD_DIR4)/.configured: $(GCC_BUILD_DIR4)/.prepared
--disable-multilib \
$(GCC_TLS) \
$(GCC_SHARED_LIBGCC) \
- $(GCC_WITH_TARGET_GMP) \
- $(GCC_WITH_TARGET_MPFR) \
- $(GCC_WITH_TARGET_MPC) \
$(DISABLE_NLS) \
$(THREADS) \
$(GCC_DECIMAL_FLOAT) \