summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-28 12:03:58 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-28 12:03:58 +0000
commit93ab6d302188ecaa40446d6511dab84e0e25aa46 (patch)
tree88fe90ed6f930eb921bd650705c4923c81d7220c /toolchain/gcc
parentf27735d605b6cce4759687b762aa8d5953ddb9ec (diff)
- add an experimental BR2_PREFER_IMA.
Currently disfunctional for gcc-4.2 due to PR30620 and possibly others
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in.28
-rw-r--r--toolchain/gcc/Makefile.in14
2 files changed, 22 insertions, 0 deletions
diff --git a/toolchain/gcc/Config.in.2 b/toolchain/gcc/Config.in.2
index 24b316307..d83502ba1 100644
--- a/toolchain/gcc/Config.in.2
+++ b/toolchain/gcc/Config.in.2
@@ -5,3 +5,11 @@ config BR2_PACKAGE_GCC_TARGET
help
If you want the target system to be able to run
binutils/gcc and compile native code, say Y here.
+
+config BR2_EXTRA_TARGET_GCC_CONFIG_OPTIONS
+ string "Additional target gcc options"
+ default ""
+ help
+ Any additional target gcc options you may want to include....
+ Including, but not limited to --disable-checking etc.
+ Refer to */configure in your gcc sources.
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 1b6e24133..c325b6a43 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -55,5 +55,19 @@ TARGET_GCC_FLAGS= CFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
BOOT_CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)"
ifeq ($(strip $(BR2_PACKAGE_GCC_TARGET)),y)
+# pull in config opts from the user
+EXTRA_TARGET_GCC_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_TARGET_GCC_CONFIG_OPTIONS)))
+#"))
+
+ifeq ($(BR2_PREFER_IMA),y)
+# >= 4.2
+ifeq ($(findstring 4.2,$(GCC_VERSION)),4.2)
+EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--enable-intermodule
+endif
+ifeq ($(findstring 4.3,$(GCC_VERSION)),4.3)
+EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--enable-intermodule
+endif
+endif # BR2_PREFER_IMA=y
+
TARGETS+=gcc_target
endif