summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-01-17 09:13:42 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-19 17:19:42 +0100
commit9bc58a42af830ecccfdb6c1d4f837356567c6386 (patch)
tree11aa5b45b1a9104b37ee18cffceb0bb61c82db75 /toolchain/gcc
parentdea0b13403e2696046d1469f691945a74545127e (diff)
toolchain: only fetch gcc/gmp/mpfr/mpc when using a buildroot toolchain
Closes #3103 gcc/gmp/mpfr/mpc are only needed when using an internal buildroot toolchain, so only add them to HOST_SOURCE then. Otherwise we get some nasty fetch error when doing "make source" [Peter: add gmpc/mpfr/mpc and reword commit text] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 80bed5eff..2c857dce5 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -109,12 +109,16 @@ endif
GCC_WITH_HOST_GMP = --with-gmp=$(HOST_DIR)/usr
GCC_WITH_HOST_MPFR = --with-mpfr=$(HOST_DIR)/usr
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
HOST_SOURCE += host-gmp-source host-mpfr-source
+endif
GCC_HOST_PREREQ = host-gmp host-mpfr
ifeq ($(findstring x4.5.,x$(GCC_VERSION)),x4.5.)
GCC_WITH_HOST_MPC = --with-mpc=$(HOST_DIR)/usr
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
HOST_SOURCE += host-mpc-source
+endif
GCC_HOST_PREREQ += host-mpc
endif
@@ -152,7 +156,9 @@ GCC_CONF_ENV:=acx_cv_prog_cc_pedantic__Wno_long_long__Wno_variadic_macros_______
acx_cv_prog_cc_warning__Wno_overlength_strings=no
endif
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
HOST_SOURCE+=gcc-source
+endif
$(DL_DIR)/$(GCC_SOURCE):
mkdir -p $(DL_DIR)