summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-07 07:34:37 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-07 07:34:37 +0000
commite3695fd1af1ae748e1dfbe62e4e3142f237fb97e (patch)
treec087d5e82ba03db8a4244affac319c7ec0aa4d7b /toolchain/gcc
parent4df454e97441f47c17dcaa1cbe434487469d0506 (diff)
Avoid stripping a script file
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index c57b5ab86..dd3ad0978 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -249,7 +249,15 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
fi
# Strip the host binaries
ifeq ($(GCC_STRIP_HOST_BINARIES),true)
- -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/*
+ if [ -e $(STAGING_DIR)/usr/bin/*-gccbug ] ; then \
+ mkdir -p "$(STAGING_DIR)/tmp" ; \
+ mv $(STAGING_DIR)/usr/bin/*-gccbug $(STAGING_DIR)/tmp ; \
+ -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/* ; \
+ mv $(STAGING_DIR)/tmp/*-gccbug $(STAGING_DIR)/usr/bin ; \
+ rmdir "$(STAGING_DIR)/tmp" ; \
+ else \
+ -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/* ; \
+ fi
endif
# Make sure we have 'cc'.
if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ] ; then \