summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-02-25 17:27:50 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-02-25 17:27:50 +0100
commitf561763e9189d668001004f5a603738c1ba7ce7c (patch)
tree152c4c286eb988d8da5091385dbcd73b5b142784 /toolchain/gcc
parentf389a9ce2fd105f0603c9ede71fdbeee5f851edd (diff)
gmp/mpfr: make sure host builds add source targets to HOST_SOURCE
Closes #1183. When gmp/mpfr is needed for the host (E.G. when using an internal toolchain), the host-lib{gmp,mpfr}-source targets weren't added to HOST_SOURCE, so make source / external-deps didn't handle them. Notice that we have the same issue with the new host package support, there we should probably use HOST_<package>_DEPENDENCIES for -source dependencies. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index dcca431db..cf76e8ad1 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -107,6 +107,7 @@ endif
ifndef GCC_NO_MPFR
GCC_WITH_HOST_GMP=--with-gmp=$(GMP_HOST_DIR)
GCC_WITH_HOST_MPFR=--with-mpfr=$(MPFR_HOST_DIR)
+HOST_SOURCE += host-libgmp-source host-libmpfr-source
ifeq ($(BR2_INSTALL_FORTRAN),y)
GCC_TARGET_LANGUAGES:=$(GCC_TARGET_LANGUAGES),fortran