summaryrefslogtreecommitdiff
path: root/toolchain/gdb/6.5/600-fix-compile-flag-mismatch.patch
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2008-07-01 21:35:33 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2008-07-01 21:35:33 +0000
commit38ca54a71911d431c43b88d1bdb2c747985a1565 (patch)
treecff029141bbc2a9dd6e51dc41a939a34c3d0e447 /toolchain/gdb/6.5/600-fix-compile-flag-mismatch.patch
parent49b38b5009eef8e59936d0619c3634b07664b28a (diff)
Fix gbd-6.5, courtesy Fathi Boudra
Diffstat (limited to 'toolchain/gdb/6.5/600-fix-compile-flag-mismatch.patch')
-rw-r--r--toolchain/gdb/6.5/600-fix-compile-flag-mismatch.patch41
1 files changed, 18 insertions, 23 deletions
diff --git a/toolchain/gdb/6.5/600-fix-compile-flag-mismatch.patch b/toolchain/gdb/6.5/600-fix-compile-flag-mismatch.patch
index ba98482d8..08100bfb8 100644
--- a/toolchain/gdb/6.5/600-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/6.5/600-fix-compile-flag-mismatch.patch
@@ -1,6 +1,5 @@
-diff -ur gdb-6.4/gdb/configure gdb-6.4-patched/gdb/configure
---- gdb-6.4/gdb/configure 2005-07-25 10:08:40.000000000 -0500
-+++ gdb-6.4-patched/gdb/configure 2007-02-05 13:22:36.000000000 -0600
+--- a/gdb/configure
++++ b/gdb/configure
@@ -309,7 +309,7 @@
# include <unistd.h>
#endif"
@@ -10,7 +9,7 @@ diff -ur gdb-6.4/gdb/configure gdb-6.4-patched/gdb/configure
ac_subdirs_all="$ac_subdirs_all gdbtk"
ac_subdirs_all="$ac_subdirs_all multi-ice"
ac_subdirs_all="$ac_subdirs_all gdbserver"
-@@ -5940,7 +5940,7 @@
+@@ -5939,7 +5939,7 @@
@@ -18,10 +17,9 @@ diff -ur gdb-6.4/gdb/configure gdb-6.4-patched/gdb/configure
+subdirs="$subdirs doc"
- . $srcdir/configure.host
-diff -ur gdb-6.4/gdb/gdbserver/configure gdb-6.4-patched/gdb/gdbserver/configure
---- gdb-6.4/gdb/gdbserver/configure 2005-09-17 18:14:37.000000000 -0500
-+++ gdb-6.4-patched/gdb/gdbserver/configure 2007-02-05 13:22:58.000000000 -0600
+ # Provide defaults for some variables set by the per-host and per-target
+--- a/gdb/gdbserver/configure
++++ b/gdb/gdbserver/configure
@@ -1239,7 +1239,7 @@
ac_cache_corrupted=: ;;
,);;
@@ -31,9 +29,8 @@ diff -ur gdb-6.4/gdb/gdbserver/configure gdb-6.4-patched/gdb/gdbserver/configure
{ echo "$as_me:$LINENO: error: \`$ac_var' has changed since the previous run:" >&5
echo "$as_me: error: \`$ac_var' has changed since the previous run:" >&2;}
{ echo "$as_me:$LINENO: former value: $ac_old_val" >&5
-diff -ur gdb-6.4/gdb/testsuite/configure gdb-6.4-patched/gdb/testsuite/configure
---- gdb-6.4/gdb/testsuite/configure 2005-04-11 09:13:12.000000000 -0500
-+++ gdb-6.4-patched/gdb/testsuite/configure 2007-02-05 13:22:36.000000000 -0600
+--- a/gdb/testsuite/configure
++++ b/gdb/testsuite/configure
@@ -1248,7 +1248,7 @@
ac_cache_corrupted=: ;;
,);;
@@ -43,27 +40,25 @@ diff -ur gdb-6.4/gdb/testsuite/configure gdb-6.4-patched/gdb/testsuite/configure
{ echo "$as_me:$LINENO: error: \`$ac_var' has changed since the previous run:" >&5
echo "$as_me: error: \`$ac_var' has changed since the previous run:" >&2;}
{ echo "$as_me:$LINENO: former value: $ac_old_val" >&5
-diff -ur gdb-6.4/Makefile.in gdb-6.4-patched/Makefile.in
---- gdb-6.4/Makefile.in 2005-12-01 23:29:54.000000000 -0600
-+++ gdb-6.4-patched/Makefile.in 2007-02-05 13:22:36.000000000 -0600
-@@ -383,7 +383,7 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -329,7 +329,7 @@
# CFLAGS will be just -g. We want to ensure that TARGET libraries
# (which we know are built with gcc) are built with optimizations so
# prepend -O2 when setting CFLAGS_FOR_TARGET.
-CFLAGS_FOR_TARGET = -O2 $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
+CFLAGS_FOR_TARGET = $(strip $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET))
SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
-
- # If GCC_FOR_TARGET is not overriden on the command line, then this
-diff -ur gdb-6.4/Makefile.tpl gdb-6.4-patched/Makefile.tpl
---- gdb-6.4/Makefile.tpl 2005-10-22 05:37:55.000000000 -0500
-+++ gdb-6.4-patched/Makefile.tpl 2007-02-05 13:22:36.000000000 -0600
-@@ -386,7 +386,7 @@
+ CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
+ LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
+--- a/Makefile.tpl
++++ b/Makefile.tpl
+@@ -332,7 +332,7 @@
# CFLAGS will be just -g. We want to ensure that TARGET libraries
# (which we know are built with gcc) are built with optimizations so
# prepend -O2 when setting CFLAGS_FOR_TARGET.
-CFLAGS_FOR_TARGET = -O2 $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
+CFLAGS_FOR_TARGET = $(strip $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET))
SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
-
- # If GCC_FOR_TARGET is not overriden on the command line, then this
+ CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
+ LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)