summaryrefslogtreecommitdiff
path: root/toolchain/gdb/Config.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-14 11:38:58 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-14 23:54:43 +0100
commit9f21bfee0877be5ec1e3fe3a8cb98fa7de539827 (patch)
tree9a07989ab37b5c953ac1f515ef13f487b1966700 /toolchain/gdb/Config.in
parent9e172b3f9178c22d167e4b4c3698bc0fe5bd9228 (diff)
gdb: add avr32 special verson
* Add a new gdb version for AVR32 in Config.in * Use a special mirror for this gdb version in gdb.mk * Do not try to apply patches when the patch directory does not exist in gdb.mk Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/gdb/Config.in')
-rw-r--r--toolchain/gdb/Config.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/toolchain/gdb/Config.in b/toolchain/gdb/Config.in
index e193fb93c..947cd1137 100644
--- a/toolchain/gdb/Config.in
+++ b/toolchain/gdb/Config.in
@@ -20,7 +20,7 @@ config BR2_PACKAGE_GDB_HOST
choice
prompt "GDB debugger Version"
default BR2_GDB_VERSION_6_8 if !BR2_avr32
- default BR2_GDB_VERSION_6_7_1 if BR2_avr32
+ default BR2_GDB_VERSION_6_7_1_AVR32_2_1_5 if BR2_avr32
depends on BR2_PACKAGE_GDB || BR2_PACKAGE_GDB_SERVER || BR2_PACKAGE_GDB_HOST
help
Select the version of gdb you wish to use.
@@ -43,6 +43,10 @@ choice
config BR2_GDB_VERSION_6_7_1
bool "gdb 6.7.1"
+ config BR2_GDB_VERSION_6_7_1_AVR32_2_1_5
+ depends on BR2_avr32
+ bool "gdb 6.7.1-avr32-2.1.5"
+
config BR2_GDB_VERSION_6_8
bool "gdb 6.8"
depends on !BR2_avr32
@@ -55,4 +59,5 @@ config BR2_GDB_VERSION
default "6.5" if BR2_GDB_VERSION_6_5
default "6.6" if BR2_GDB_VERSION_6_6
default "6.7.1" if BR2_GDB_VERSION_6_7_1
+ default "6.7.1-avr32-2.1.5" if BR2_GDB_VERSION_6_7_1_AVR32_2_1_5
default "6.8" if BR2_GDB_VERSION_6_8