summaryrefslogtreecommitdiff
path: root/toolchain/gdb/gdb.mk
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2006-07-05 05:12:51 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2006-07-05 05:12:51 +0000
commit552c41e491f009656ac905301ab759f1df7fc9cf (patch)
treea20becb9c6bc61543ea5cd77261e1da3e469e8b5 /toolchain/gdb/gdb.mk
parentc9306ec90c5fb41d20096da8f902e9aff1790e0e (diff)
Automate the usage of '--disable-gdbmi' to be used only with GDB versions less than 6.4, if they are even used anymore.
Diffstat (limited to 'toolchain/gdb/gdb.mk')
-rw-r--r--toolchain/gdb/gdb.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index be3a388f0..6b8a0df6f 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -19,10 +19,16 @@ GDB_CAT:=bzcat
GDB_DIR:=$(TOOL_BUILD_DIR)/gdb-$(GDB_VERSION)
-# NOTE: This option should not be used with newer gdb versions.
+# NOTE: This option should not be used with gdb versions 6.4 and above.
+ifeq ($(GDB_VERSION),6.2.1)
DISABLE_GDBMI:=--disable-gdbmi
endif
+ifeq ($(GDB_VERSION),6.3)
+DISABLE_GDBMI:=--disable-gdbmi
+endif
+endif
+
$(DL_DIR)/$(GDB_SOURCE):
$(WGET) -P $(DL_DIR) $(GDB_SITE)/$(GDB_SOURCE)