summaryrefslogtreecommitdiff
path: root/toolchain/gdb/gdb.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-03-02 08:55:16 +0000
committerEric Andersen <andersen@codepoet.org>2005-03-02 08:55:16 +0000
commit75e551047f5aab5fba784f1b18aaff61e6349032 (patch)
treea6032b4a8f1d67072c18e5751db18a110ab7e0b6 /toolchain/gdb/gdb.mk
parent8cbab86501e43cefa3ca30e55654740878d32114 (diff)
kill off support for gdb 5.3
Diffstat (limited to 'toolchain/gdb/gdb.mk')
-rw-r--r--toolchain/gdb/gdb.mk11
1 files changed, 0 insertions, 11 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 9aa5f8e07..56077ccb5 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -7,14 +7,8 @@ GDB_VERSION:=$(strip $(subst ",, $(BR2_GDB_VERSION)))
#"
GDB_SITE:=http://ftp.gnu.org/gnu/gdb
-
-ifeq ($(GDB_VERSION),5.3)
-GDB_SOURCE:=gdb-$(GDB_VERSION).tar.gz
-GDB_CAT:=zcat
-else
GDB_SOURCE:=gdb-$(GDB_VERSION).tar.bz2
GDB_CAT:=bzcat
-endif
GDB_DIR:=$(TOOL_BUILD_DIR)/gdb-$(GDB_VERSION)
@@ -27,11 +21,6 @@ $(GDB_DIR)/.unpacked: $(DL_DIR)/$(GDB_SOURCE)
# Copy a config.sub from gcc. This is only necessary until
# gdb's config.sub supports <arch>-linux-uclibc tuples.
# Should probably integrate this into the patch.
-ifeq ($(GDB_VERSION),5.3)
- chmod u+x $(GDB_DIR)/gdb/gdbserver/configure
- cp $(GCC_DIR)/config.sub $(GDB_DIR)
- cp $(GCC_DIR)/config.sub $(GDB_DIR)/readline/support/
-endif
touch $(GDB_DIR)/.unpacked
######################################################################