summaryrefslogtreecommitdiff
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2010-02-08 16:56:08 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-02-09 11:44:20 +0100
commit4b7432119521be1339f49794983d28ba3b0b8f86 (patch)
tree3f2d48be1efaba86ca99ccbc723b5daafc207167 /toolchain/gdb
parent1b4e71a1392d1be8a0281a0b7eada3eaa9c984bc (diff)
toolchain/gdb: get rid of another legacy and unused variable
BR2_VENDOR_GDB_VERSION and VENDOR_GDB_VERSION are no longer settable. The only user is gdb, and it's totally useless in this case. Signed-off-by: Yann E. MORIN <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/gdb.mk12
1 files changed, 5 insertions, 7 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 02da1527e..62889592f 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -5,20 +5,18 @@
######################################################################
GDB_VERSION:=$(call qstrip,$(BR2_GDB_VERSION))
-GDB_OFFICIAL_VERSION:=$(GDB_VERSION)$(VENDOR_GDB_RELEASE)
-
-GDB_SOURCE:=gdb-$(GDB_OFFICIAL_VERSION).tar.bz2
+GDB_SOURCE:=gdb-$(GDB_VERSION).tar.bz2
GDB_CAT:=$(BZCAT)
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_SOURCE),y)
GDB_SITE:=$(VENDOR_SITE)
- GDB_PATCH_DIR:=toolchain/gdb/ext_source/$(VENDOR_PATCH_DIR)/$(GDB_OFFICIAL_VERSION)
+ GDB_PATCH_DIR:=toolchain/gdb/ext_source/$(VENDOR_PATCH_DIR)/$(GDB_VERSION)
else ifeq ($(findstring avr32,$(GDB_VERSION)),avr32)
GDB_SITE:=ftp://www.at91.com/pub/buildroot/
- GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
+ GDB_PATCH_DIR:=toolchain/gdb/$(GDB_VERSION)
else
GDB_SITE:=$(BR2_GNU_MIRROR)/gdb
- GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
+ GDB_PATCH_DIR:=toolchain/gdb/$(GDB_VERSION)
endif
ifneq ($(filter xtensa%,$(ARCH)),)
@@ -26,7 +24,7 @@ include target/xtensa/patch.in
GDB_PATCH_EXTRA:=$(call XTENSA_PATCH,gdb,$(GDB_PATCH_DIR),. ..)
endif
-GDB_DIR:=$(TOOLCHAIN_DIR)/gdb-$(GDB_OFFICIAL_VERSION)
+GDB_DIR:=$(TOOLCHAIN_DIR)/gdb-$(GDB_VERSION)
$(DL_DIR)/$(GDB_SOURCE):
$(call DOWNLOAD,$(GDB_SITE),$(GDB_SOURCE))