summaryrefslogtreecommitdiff
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-08-24 07:48:22 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-08-24 07:48:22 +0000
commit5a5c59956bfb1a5b03848a058c1626edc59625eb (patch)
tree82cddf40e9a9e518aad2d88b9aaba33958671eb8 /toolchain/gdb
parent6d31b020b026534a74b6e4ef9ccd5174a131fd10 (diff)
toolchain/gdb: unbreak target gdb support
r22624 (Ulf: Add prepatched AVR32 gcc-4.2.2 toolchain) broke target gdb support as it tries to apply gdb patches twice. Unbreak it. Closes #3954.
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/gdb.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 6220cd9cb..aa46380f2 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -62,10 +62,6 @@ endif
touch $@
gdb-patched: $(GDB_DIR)/.unpacked
-$(GDB_DIR)/.patched: $(GDB_DIR)/.unpacked
- toolchain/patch-kernel.sh $(GDB_DIR) $(GDB_PATCH_DIR) \*.patch
- $(CONFIG_UPDATE) $(GDB_DIR)
- touch $@
gdb-dirclean:
rm -rf $(GDB_DIR)
@@ -88,7 +84,7 @@ GDB_TARGET_CONFIGURE_VARS:= \
bash_cv_func_sigsetjmp=present \
bash_cv_have_mbstate_t=yes
-$(GDB_TARGET_DIR)/.configured: $(GDB_DIR)/.patched
+$(GDB_TARGET_DIR)/.configured: $(GDB_DIR)/.unpacked
mkdir -p $(GDB_TARGET_DIR)
(cd $(GDB_TARGET_DIR); \
gdb_cv_func_sigsetjmp=yes \